Главная
   Документация
      Ansible
      Asterisk
      CentOS
      Debian
      Docker
      FreeBSD
      MySQL
      openHAB
      PostgreSQL
      Raspberry Pi
      Ubuntu
      WWW
      zoneminder
      Разное




Главная Документация Debian › Debian, Ubuntu apt - ошибка KEYEXPIRED

Debian, Ubuntu apt - ошибка KEYEXPIRED

Автор:

Статья написана 2017-02-19 12:29:00
Последние правки 2018-08-10 09:54:36

Обновляем просроченный ключ. Данный мануал подходит также и для Ubuntu.

Ошибка apt:
W: Ошибка GPG: http://repo.mysql.com jessie InRelease: Следующие подписи неверные: KEYEXPIRED 1487236823 KEYEXPIRED 1487236823 KEYEXPIRED 1487236823
или
W: GPG error: ftp://ftp.fr.debian.org stable/non-US Release: The following signatures were invalid: KEYEXPIRED 1138684904
Решение:
# apt-key list | grep expired
или (если у вас всё на русском)
# apt-key list | grep просрочен
pub   1024D/5072E1F5 2003-02-03 [просрочен с: 2017-02-16]
обновляем ключ (Debian):
apt-key adv --recv-keys --keyserver keys.gnupg.net 5072E1F5
обновляем ключ (Ubuntu):
apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 5072E1F5


Связанные странички:
Docker - установка в Ubuntu
OpenVPN сервер на Ubuntu
Ubuntu, пакеты (+Debian)
Debian, установка clamav.
Ubuntu 18.04, настраиваем сеть
Всё о дате и времени в Debian
Haproxy - установка и настройка в Ubuntu
OTRS 6 - устанавливаем на Ubuntu 18.10
Ошибка - no server suitable for synchronization found (Ubuntu)
Получаем SSL сертификаты от Let's Encrypt при помощи acme.sh.